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ScheduleR User Manual 
Introduction 
ScheduleR User Manual is to help you to use Scheduler program. It can set up schedules 
with WinEDT .N99 message files and send them to signs. 

Installation 
Follow the instructions to install ScheduleR.  

1. Make sure you have administrator rights on your PC. 
2. If your system is Windows XP, skip this step and go to step 3. For other Windows 

system, run “InstMsi2.0.exe” to install Microsoft Windows Installer version 2.0. 

o If it asks you to restart Windows, restart Windows immediately. 
o If a warning box shows “The specified service already exists” after 

running it, click OK. It means the Windows Installer 2.0 is already 
installed so you can skip this step and go to step 3. 

3. Run “Setup_Scheduler_v1.14.exe” to install ScheduleR program and MSXML. 
Default installation directory is “C:\Program Files\ScheduleR”. Default Program 
Group is “Optec Displays\ScheduleR v1.14”.  

4. After installation complete, you can start running ScheduleR. 

o Double-click “ScheduleR” icon on the desktop. 
o Or click “Start” - “Programs” - “Optec Displays” - “ScheduleR v1.14” - 

“ScheduleR”. 

Uninstallation 

To uninstall the program, go to the start menu, run "Programs\Optec Displays\ScheduleR 
v1.14\Uninstall ScheduleR". 

Create Schedules 

Double-click “Scheduler” icon on the desktop or choose “Programs\Optec 
Displays\ScheduleR v1.14\Run ScheduleR” from the Start Menu. 

Before sending schedules to the sign, you have to create schedules and saved as .SHX file.  
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A single schedule is a line item (row) in the overall scheduler data view. A ScheduleR 
file is an aggregate of all defined schedules.  

 
Tool Bar 

Toolbar buttons are shortcuts to the menu items, you can see them under the menu bar. 

 
 

You can also get hints about each toolbar when you put your mouse arrow on the specific 
button for one second.  

Create a New ScheduleR File 

To create a new schedule file with extension .SHX, choose “File->New” from the main 
menu or click on the “New” button in the toolbar or press “Ctrl+N” keystroke. Save 
files whenever you changed schedules. 

Save to a ScheduleR File 

Save your schedules as “filename.SHX”. To save it, you can choose “File->Save” from 
the main menu or click on the Save button in the toolbar or press “Ctrl+S” keystroke.  
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Open an existing ScheduleR File 

To open an existing schedule file, choose “File->Open” from the main menu or click on 
the Open button in the toolbar or press “Ctrl+O” keystroke. Select .SHX files. 

After you create a new or open an existing ScheduleR file, you can add, edit and delete 
schedules on the screen and save them to ScheduleR file. 

Add a New Schedule 

To add a new schedule, move the cursor to the blank row and double-click the left button 
of the mouse or click right button of the mouse. Or choose “Edit” - “Add” from the main 

menu as below or click on the in the toolbar. The new schedule will be added at the 
end of all schedules on the screen. This added schedule has default data but contains no 
message. You have to add .N99 files and change the schedule data. 

Change Schedules 

To change a schedule, move the cursor to the row of the schedule and double click the 
left button or click the right button of the mouse. An Edit Schedule will be shown as 
below. 
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There are three types of schedules. Default is continuously. 

• Daily: For example, when start date is 3/3/2004, start time is 07:00:00AM, end date is 
3/18/2004 and end time is 9:59:59PM. Schedule runs from 7AM to 9:59:59PM everyday 
from 3/3/2004 to 3/18/2004. However, the schedule does not include 12AM to 7AM and 
10PM to 12PM everyday from 3/3/2004 to 3/18/2004. Note: In this type, End Time 
must be greater than Start Time. 

• Continuously: You can have continous schedules for a long period. For example, you 
can have a schedule from 8AM on 10/3/2004 to 7:59:59PM on 11/18/2004. However, 
this schedule is equal to 3 daily schedules. Note: The maximum allowed continuous 
schedules are less than daily schedules. 

• Weekly: This is weekly schedule. You can select one or more weekdays, for example, 
every Friday, Saturday and Sunday from 3/3/2004 to 3/18/2004. Note: In this type, End 
Time must be greater than Start Time. The maximum allowed weekly schedules are 
less than daily schedules. 



 7

Note: The total maximum 19 schedules is allowed for each sign ID. To calculate the total 
number of schedules for each sign ID, add the sum of the number of daily schedule and 
the sum of the number of continuous schedules multiplying by 3 and the sum of the 
number of selected weekdays for every weekly schedule. For example, if you want to 
send schedules with 2 daily schedules, 4 continous schedules and a weekly schedule with 
3 weekdays selected. Then you may have total schedules = 2 + 4 * 3 + 1 * 3 = 17. Thus it 
is not larger than maximum 19 schedules and can be sent to the sign. 

To change the Start date or End date, click the date picker and the calendar will be 
displayed for you to change it or you can edit it yourself. Format is MM/DD/YYYY. MM 
is month. DD is date of the month. YYYY is year. Default is today. Note: End Date 
must be equal or greater than Start Date. 

To change the Start Time or End Time, click the time picker up or down or edit it by 
yourself. Format is HH:mm:SS AM/PM. HH is hour, mm is minute, SS is second. 
Default Start Time is 12:00:00 AM and End time is 11:59:59PM. Note: You can only 
change hour, minute and AM/PM, not the second. Because the sign changes display by a 
minute change, not by second. 

 

Message Files 

To add WinEDT .N99 files, move the cursor to the row of Message Files Block and click 
“Browse File” button to add .N99 files. After clicking ok when selected any file, you can 
see each .N99 files is separated by semicolon (;), and the extension .N99 is not shown on 
the filename. You can also preview, preview all, delete or clear all files shown here. Note: 
Do not leave Message files blank . 
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ID or Group 

If you want different IDs displaying different messages, Select an ID, default is 1. Click 
up and down to change the ID value. 

If you want multiple signs with different IDs displaying the same message at the same 
time, you may add a group name for these Ids. Select “Group” and edit the Group as 
“GroupName”, and IDs as “1, 2, 5”, including IDs 1, 2, and 5. Put ID numbers and each 
ID number is separated by two characters, a comma and a blank. 

Location is to set a Location name to represent for the same communication, for example, 
if you have communication link com port 1 and baud rate 9600. You can set a Location 
name as “Local1” for it. 

Communication: 

There are three communication types: Local (Serial Port), Modem and Internet. You can 
choose either type for communication. 

1. Local: Use direct link, RS-232 port. Default is Serial Port = 1, Baud Rate = 9600. 
Click up and down arrow to change the com port number. Scroll up and down to 
change the baud rate. 

2. Modem: Enter a Telephone number and click the “Settings” button to change the 
serial port settings connected to this telephone modem, the screen will appear as 
below.  

 

3. Internet: Set sign's Internet IP address with xxx.xxx.xxx.xxx (ex: 192.168.0.1) 
and Internet Port number (0 ~ 65535). An optional location is available. 

Copy, Cut and Paste Schedules 

You can copy or cut selected schedules and paste to the end of the schedules. 

To cut schedules or rows, select the rows or schedules you want to move to the clipboard. 
Choose Edit->Cut from the main menu or click on the Cut button in the toolbar.  
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To copy schedules or rows, select the rows or schedules you want to copy. Choose "Edit-
>Copy" from the main menu or click on the Copy button in the toolbar.  

To paste schedules from the clipboard, choose “Edit->Paste” from the main menu or click 
on the Paste button in the toolbar. The schedules from clipboard will be appended to 
the bottom of the schedules on the screen. 

Delete Schedules 

There are two steps for this: 

1.      To delete a schedule (or a row), move your mouse and click on the schedule you 
want to delete, the background color of the schedule will change from white to blue.  

To delete multiple schedules, press “Ctrl” on the keyboard and click on these schedules 
together. 

2.      Then choose “Edit->Delete” from the main menu or click on the Delete button 
in the toolbar. 

Send Schedules 
 

There are three ways to send schedules as below. Click the arrow button on the right of 
the “Send Immediately” toolbar, and select one of them. Or click menu “Send” and select 
one send method. 
1.      Send Immediately: 

You can send schedules to the sign immediately and the schedules on the sign will be 
immediately updated. Click “Send” - “Immediately” from the main menu or the toolbar 

Send button. Note: Remember to save schedule “.SHX” files before sending schedules. 

2.      Autosend Active: 

If you want to autosend schedules on a particular time once everyday, use autosend. Thus 
the schedules on the sign will be updated once everyday. 
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Click menu “Send” - “Start Auto Send” and change the starting autosend time, for 
example, if you want to autosend on 6AM everyday, change it to “6:00:00AM” and click 
OK. 

  
 

Note: In autosend mode, you can use large number of rety resending times. 

To auto start autosending function on windows startup, choose menu “Settings -> Setup 
auto start Autosending”. Check the “Auto start Autosending on windows startup”. 
However, to disable autostart autosending, uncheck the box. Default is unchecked, i.e., 
autostart off. 

 

Note: Do not shutdown, standby or hibernate computer in autosending mode. Go to 
“Start” -> “Control Panel” -> “Power Options” -> “Power schemes” and select 
“Always On” to make the computer always on.  

3.      Autosend Stop: 

To stop the autosend, choose “Send->Stop Auto Send” from the main menu. 

Resending 
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Before sending schedules, you can change the number of times to retry sending schedules.  

For Local resending, choose “Settings” -> “Setup Local resending” from the main menu. 

 

a. To try to wake up ID multiple times, please set “ID Wake up retry times” 
field. 

b. To resend ID if failed, please set “ID Resend times” field. 
c. To reopen direct link COM port, please set up “Retry times if Local fail”. 

For Telephone Modem Resending, choose “Settings” -> “Setup Modem Redial” from 
the main menu and a screen will be shown below.  

 
 

a. To resend a schedule if send status is failed, set up the number of times in 
the field of “Reconnect Location times if failed”.  

b. To set telephone redial times if busy and redial after number of seconds, 
set the specified field.  

c. To set ID wakeup retry times if failed on wakeup, set the specified field.  
d. Set the destination location name in Location field and Tel number in TEL 

field.  

To change the Internet resending settings, choose “Settings” -> “Setup Internet 
Resending” from the main menu and a screen will be shown below.  
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a. To set ID wakeup retry times if failed on wakeup, set the specified field.  
b. To resend schedules to Sign ID if send status is failed, set up the number 

of times in the field of “ID Resend times if failed”. 
c. To set resend times for the same Internet IP if failed, set the specified field. 

 

Verify Send Schedules 
The status of sending schedules on the screen will be shown and updated when sending. 

 
The Status field shows the send status and the send time shows the send time. The 
messages shown on status field are listed as below: 

1.      Sent OK: This schedule is sent successfully for any connection type. This is the 
only successful status. 

The below status are all failed or cancelled status. 

2.      Local Fail: Unable to open serial port or Serial Port is not available or failed. 

3.      Group Fail or ID fail: Group or ID are not connected successfully or wrong 
connection type. 

4.      LOC Fail: The destination location dialed by modem is not able to answer your call 
or not connected ok. 

5.      No DialTone: No dial tone for modem. 
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6.      No Carrier: No carrier for modem. 

7.      Modem Fail: Modem is not functioning properly. 

8.      Connect Fail: Cannot connect to the destination IP address with port number. 

9.      Socket Fail: Internet Socket open fail. 

10.  Send Fail: Fail to send data on Internet Connection. 

11.  Recv Fail: Fail to receive data on Internet connection. 

12.  Schedule Fail: The schedules for the this ID or Group is over limit: 19. 

13.  Memory Fail: Out of memory in this ID or Group. 

14.  Cancelled: User cancelled sending. 

15.  Not Sent: The schedule is not sent due to past time. 

16.  Unknown: Unknown status. 

To verify sent schedules by ID/Group, choose “Verify->Verify by ID/Group” from 
main menu. A dialog will be shown below. 

 
  

Choose ID or Group at specified location, for example, ID 1 at “LOC Loc1” and press 
“Verify Send Status” to see the last sent status for this ID/Group. “LOC Loc1” means 
location “Loc1”. 

To preview current running message on the ID/Group, select the ID or Group at a 
location and press “View Current Running message” button. The sent time for running 
message is shown in the Sent Time. 
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Print 
Print Setup 

To setup the printer, choose “File” – “Print Setup” from the main menu or click on the 
Print Setup button in the toolbar. Please change Orientation to “landscape” mode. 

Print Preview 

Before printing schedules, you can preview your schedules on the screen. Choose “File” - 
“Print Preview” from the main menu or click on the Print Preview button in the 
toolbar. The example, sample2.shx, is shown in the following figure.  

 

The first line is “Schedule File: [filename].shx”. The second line is the title of every field 
for the schedule. Starting from the third line, the schedules are dumped on the screen. If a 
schedule includes multiple files, it print multiple rows. 

There are seven buttons on the top of the screen. You can click on “Zoom In” or “Zoom 
Out” button to increase or decrease the viewing size. You can print it by click on “Print” 
button. To finish previewing, click on “Close” button and it will go back to the Scheduler 
main program.  

Print 

To print the schedules in the screen to the printer, choose “File” – “Print” from the main 
menu or click on the Print button in the toolbar. 

View 

Toolbar 

You can activate or deactivate the toolbar view, check or uncheck “View->Toolbar” from 
the main menu. 

Status Bar 
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The Status Bar is on the bottom of the program window; it displays text about the current 
status of the program or detailed tool tips of toolbar buttons. You can activate or 
deactivate the toolbar view, check or uncheck “View” - “Status Bar” from the main menu. 

Help 

To see online help, Click on the toolbar or “Help” - “Contents” from the main menu. 

Version 
To get version, click “Help” - “About” from the main menu. 

FAQ/Troubleshoot 
Unable to initialize XML 

If you see an error message “Unable to initialize XML” when program attempts to save 
files, then Windows Installer 2.0, ScheduleR and MSXML are not installed well. 
Reinstall the software by following the steps in Installation section. 

Contact Us 

Optec Displays, Inc.  
530 S. 6th Ave,  
City of Industry, CA 91746  
Customer Support: 626-369-7188 or 1800-876-1668  

 

 

 


